Why is PyMongo 3 giving ServerSelectionTimeoutError?

Posted on

Question :

Why is PyMongo 3 giving ServerSelectionTimeoutError?

I’m using:

  • Python 3.4.2
  • PyMongo 3.0.2
  • mongolab running mongod 2.6.9
  • uWSGI 2.0.10
  • CherryPy 3.7.0
  • nginx 1.6.2

uWSGI start params:

--socket --daemonize --enable-threads --threads 2 --processes 2

I setup my MongoClient ONE time:

self.mongo_client = MongoClient('mongodb://user:pw@host.mongolab.com:port/mydb')
self.db = self.mongo_client['mydb']

I try and save a JSON dict to MongoDB:

result = self.db.jobs.insert_one(job_dict)

It works via a unit test that executes the same code path to mongodb. However when I execute via CherryPy and uWSGI using an HTTP POST, I get this:

pymongo.errors.ServerSelectionTimeoutError: No servers found yet

Why am I seeing this behavior when run via CherryPy and uWSGI? Is this perhaps the new thread model in PyMongo 3?


If I run without uWSGI and nginx by using the CherryPy built-in server, the insert_one() works.

Update 1/25 4:53pm EST:

After adding some debug in PyMongo, it appears that topology._update_servers() knows that the server_type = 2 for server ‘myserver-a.mongolab.com’. However server_description.known_servers() has the server_type = 0 for server ‘myserver.mongolab.com’

This leads to the following stack trace:

result = self.db.jobs.insert_one(job_dict)
File "/usr/local/lib/python3.4/site-packages/pymongo/collection.py", line 466, in insert_one
with self._socket_for_writes() as sock_info:
File "/usr/local/lib/python3.4/contextlib.py", line 59, in __enter__
return next(self.gen)
File "/usr/local/lib/python3.4/site-packages/pymongo/mongo_client.py", line 663, in _get_socket
server = self._get_topology().select_server(selector)
File "/usr/local/lib/python3.4/site-packages/pymongo/topology.py", line 121, in select_server
File "/usr/local/lib/python3.4/site-packages/pymongo/topology.py", line 97, in select_servers
pymongo.errors.ServerSelectionTimeoutError: No servers found yet
Asked By: drfence


Answer #1:

We’re investigating this problem, tracked in PYTHON-961. You may be able to work around the issue by passing connect=False when creating instances of MongoClient. That defers background connection until the first database operation is attempted, avoiding what I suspect is a race condition between spin up of MongoClient’s monitor thread and multiprocess forking.

Answered By: drfence

Answer #2:

I fixed it for myself by downgrading from pymongo 3.0 to 2.8. No idea what’s going on.

   flask/bin/pip uninstall pymongo
   flask/bin/pip install pymongo==2.8
Answered By: Bernie Hackett

Answer #3:

As mentioned here: https://stackoverflow.com/a/54314615/8953378

I added ?ssl=true&ssl_cert_reqs=CERT_NONE to my connection string, and it fixed the issue.

so instead of:

connection_string = "mongodb+srv://<USER>:<PASSWORD>@<CLUSTER>/<COLLECTION>"

I wrote:

connection_string = "mongodb+srv://<USER>:<PASSWORD>@<CLUSTER>/<COLLECTION>?ssl=true&ssl_cert_reqs=CERT_NONE"

(Note that if you have other parameters in your connection string, you need to change the ? to & )

Answered By: Greg

Answer #4:

I had the same problem with Pymongo 3.5
Turns out replacing localhost with or corresponding ip address of your mongodb instance solves the problem.

Answered By: Alon Gouldman

Answer #5:

I am not sure if you are using the MongoDB paired with AWS Cloud service. But if you are, I found that you have to specify which IP Address you want MongoDB to have access to.

So what you need to do is add the IP Address of your host server to allow entry.

In MongoAtlas, this can be done at this page
enter image description here

I know there was already a solution to the same issue, but I didn’t find a solution that helped my situation, so wanted to post this, so others could benefit if they ever face the same problem that I do.

Answered By: Raj

Answer #6:

I encountered this too.

This could be due to pymongo3 isn’t fork safe.

I fix this by adding --lazy-apps param to uwsgi, this can avoid the “fork safe” problem.

seeing uwsgi doc preforking-vs-lazy-apps-vs-lazy.

Notice, no sure for this two having positive connection.

Answered By: cruise_lab

Answer #7:

I solved this by installing dnspython (pip install dnspython). The issue is that: “The “dnspython” module must be installed to use mongodb+srv:// URIs”

Answered By: zephor

Answer #8:

I was facing the same exception today. In my case, the proxy settings were probably blocking the connection since I could establish a successful connection to the mongodb by changing my wifi. Even if this question is marked as solved already, it can hopefully narrow down the problem for some others.

Answered By: ttfreeman

Leave a Reply

Your email address will not be published. Required fields are marked *