What is causing ImportError: No module named pkg_resources after upgrade of Python on os X?

Posted on

Question :

What is causing ImportError: No module named pkg_resources after upgrade of Python on os X?

I just updated Python to 2.6.4 on my Mac.
I installed from the dmg package.

The binary did not seem to correctly set my Python path, so I added '/usr/local/lib/python2.6/site-packages' in .bash_profile

>>> pprint.pprint(sys.path)  

Apparently that is not all the required paths because I can’t run iPython.

$ ipython  
Traceback (most recent call last):  
  File "/usr/local/bin/ipython", line 5, in <module>  
  from pkg_resources import load_entry_point  
ImportError: No module named `pkg_resources`

I’ve done Google searches and I can’t really figure out how to install pkg_resources or make sure it’s on the path.

What do I need to do to fix this?

Answer #1:

[UPDATE] TL;DR pkg_resources is provided by either Distribute or setuptools.

[UPDATE 2] As announced at PyCon 2013, the Distribute and setuptools projects have re-merged. Distribute is now deprecated and you should just use the new current setuptools. Try this:

curl -O https://bitbucket.org/pypa/setuptools/raw/bootstrap/ez_setup.py
python ez_setup.py

Or, better, use a current pip as the high level interface and which will use setuptools under the covers.

[Longer answer for OP’s specific problem]:

You don’t say in your question but I’m assuming you upgraded from the Apple-supplied Python (2.5 on 10.5 or 2.6.1 on 10.6) or that you upgraded from a python.org Python 2.5. In any of those cases, the important point is that each Python instance has its own library, including its own site-packages library, which is where additional packages are installed. (And none of them use /usr/local/lib by default, by the way.) That means you’ll need to install those additional packages you need for your new python 2.6. The easiest way to do this is to first ensure that the new python2.6 appears first on your search $PATH (that is, typing python2.6 invokes it as expected); the python2.6 installer should have modified your .bash_profile to put its framework bin directory at the front of $PATH. Then install easy_install using setuptools following the instructions there. The pkg_resources module is also automatically installed by this step.

Then use the newly-installed version of easy_install (or pip) to install ipython.

easy_install ipython


pip install ipython

It should automatically get installed to the correct site-packages location for that python instance and you should be good to go.

Answered By: Ned Deily

Answer #2:

I encountered the same ImportError. Somehow the setuptools package had been deleted in my Python environment.

To fix the issue, run the setup script for setuptools:

curl https://bitbucket.org/pypa/setuptools/raw/bootstrap/ez_setup.py | python

If you have any version of distribute, or any setuptools below 0.6, you will have to uninstall it first.*

See Installation Instructions for further details.

* If you already have a working distribute, upgrading it to the “compatibility wrapper” that switches you over to setuptools is easier. But if things are already broken, don’t try that.

Answered By: cwc

Answer #3:

In case of upgrading your python on mac os 10.7 and pkg_resources doesn’t work, the simplest way to fix this is just reinstall setuptools as Ned mentioned above.

sudo pip install setuptools --upgrade
or sudo easy_install install setuptools --upgrade
Answered By: vutran

Answer #4:

On my system (OSX 10.6) that package is at


I hope that helps you figure out if it’s missing or just not on your path.

Answered By: Bryan McLemore

Answer #5:

The reason might be because the IPython module is not in your PYTHONPATH.

If you donwload IPython and then do
python setup.py install

The setup doesn’t add the module IPython to your python path.
You might want to add it to your PYTHONPATH manually. It should work after you do :

export PYTHONPATH=/pathtoIPython:$PYTHONPATH

Add this line in your .bashrc or .profile to make it permanent.

Answered By: Ben

Answer #6:

I realize this is not related to OSX, but on an embedded system (Beagle Bone Angstrom) I had the exact same error message. Installing the following ipk packages solved it.

opkg install python-setuptools
opkg install python-pip
Answered By: Mark Lakata

Answer #7:

I got this error on Ubuntu, and the following worked for me:

Removed the dropbox binaries and download them again, by running:

sudo rm -rf /var/lib/dropbox/.dropbox-dist
dropbox start -i
Answered By: peeol

Answer #8:

I encountered with the same problem when i am working on autobahn related project.

1) So I download the setuptools.-0.9.8.tar.gz form https://pypi.python.org/packages/source/s/setuptools/ and extract it.

2 )Then i get the pkg_resources module and copy it to the folder where it needed.
**in my case that folder was C:Python27Libsite-packagesautobahn

Answered By: Nithila

Leave a Reply

Your email address will not be published. Required fields are marked *