ImportError: No module named six

Posted on

Question :

ImportError: No module named six

I’m trying to build OpenERP project, done with dependencies. It’s giving this error now

Traceback (most recent call last):
  File "openerp-client.py", line 105, in <module>
  File "modules__init__.pyo", line 23, in <module>
  File "modulesgui__init__.pyo", line 22, in <module>
  File "modulesguimain.pyo", line 33, in <module>
  File "rpc.pyo", line 29, in <module>
  File "common__init__.pyo", line 22, in <module>
  File "commoncommon.pyo", line 26, in <module>
  File "tools__init__.pyo", line 28, in <module>
  File "dateutilrelativedelta.pyo", line 12, in <module>
ImportError: No module named six

Could someone guide what’s wrong and how it can be fixed???

Answer #1:

You probably don’t have the six Python module installed. You can find it on pypi.

To install it:

$ easy_install six

(if you have pip installed, use pip install six instead)

Answered By: Sylvain Defresne

Answer #2:

If pip “says” six is installed but you’re still getting:

ImportError: No module named six.moves

try re-installing six (worked for me):

pip uninstall six
pip install six
Answered By: 3ygun

Answer #3:

On Ubuntu and Debian

apt-get install python-six

does the trick.

Use sudo apt-get install python-six if you get an error saying “permission denied”.

Answered By: user144437

Answer #4:

For Mac OS X:

pip install --ignore-installed six
Answered By: Rochan

Answer #5:

pip install --ignore-installed six

Source: 1233 thumbs up on this comment

Answered By: Tom Hale

Answer #6:

on Ubuntu Bionic (18.04), six is already install for python2 and python3 but I have the error launching Wammu.
@3ygun solution worked for me to solve

ImportError: No module named six

when launching Wammu

If it’s occurred for python3 program, six come with

pip3 install six

and if you don’t have pip3:

apt install python3-pip

with sudo under Ubuntu!

Answered By: bcag2

Answer #7:

I did the following to solve the mentioned problem. I got the mentioned problem when I was trying to run the built exe, even I successfully built the exe using pyinstaller. I did this on Windows 10.

  1. go to https://pypi.org/project/six/#files
  2. download “six-1.14.0.tar.gz (33.9 kB)”
  3. unzip it, copy and paste “six.py” into your source directory.
  4. import “six” module into your source code (import six)
  5. run source script.
Answered By: SahanWickramage

Answer #8:

In my case, six was installed for python 2.7 and for 3.7 too, and both pip install six and pip3 install six reported it as already installed, while I still had apps (particularly, the apt program itself) complaining about missing six.

The solution was to install it for python3.6 specifically:

/usr/bin/python3.6 -m pip install six
Answered By: Alpi Murányi

Leave a Reply

Your email address will not be published. Required fields are marked *