How to get pip to work behind a proxy server [duplicate]

Posted on

Question :

How to get pip to work behind a proxy server [duplicate]

I am trying to use python package manager pip to install a package and it’s dependencies from the internet. However I am behind a proxy in my college and have already set the http_proxy environment variable. But when I try to install a package like this:

pip install TwitterApi

I get this error in the log file:

Getting page http://pypi.python.org/simple/TwitterApi
Could not fetch URL http://pypi.python.org/simple/TwitterApi: <urlopen error [Errno 111] Connection refused>
Will skip URL http://pypi.python.org/simple/TwitterApi when looking for download links for TwitterApi
Getting page http://pypi.python.org/simple/
Could not fetch URL http://pypi.python.org/simple/: <urlopen error [Errno 111] Connection refused>

I even tried setting my proxy variable explicitly like this:

pip install --proxy http://user:password@proxyserver:port TwitterApi

But I still get the same error. How do I get pip to work behind a proxy server.

Answer #1:

The pip’s proxy parameter is, according to pip --help, in the form scheme://[user:passwd@]proxy.server:port

You should use the following:

pip install --proxy http://user:password@proxyserver:port TwitterApi

Also, the HTTP_PROXY env var should be respected.

Note that in earlier versions (couldn’t track down the change in the code, sorry, but the doc was updated here), you had to leave the scheme:// part out for it to work, i.e. pip install --proxy user:password@proxyserver:port

Answered By: svvac

Answer #2:

At least for pip 1.3.1, it honors the http_proxy and https_proxy environment variables. Make sure you define both, as it will access the PYPI index using https.

export https_proxy="http://<proxy.server>:<port>"
pip install TwitterApi
Answered By: petre

Answer #3:

Old thread, I know, but for future reference, the –proxy option is now passed with an “=”

Example:

$ sudo pip install --proxy=http://yourproxy:yourport package_name
Answered By: Tudor Leustean

Answer #4:

First Try to set proxy using the following command

SET HTTPS_PROXY=http://proxy.***.com:PORT#

Then Try using the command

pip install ModuleName
Answered By: Karthik C

Answer #5:

On Ubuntu, you can set proxy by using

export http_proxy=http://username:password@proxy:port
export https_proxy=http://username:password@proxy:port

or if you are having SOCKS error use

export all_proxy=http://username:password@proxy:port

Then run pip

sudo -E pip3 install {packageName}
Answered By: Gary Mendonca

Answer #6:

at least pip3 also works without “=”, however, instead of “http” you might need “https”

Final command, which worked for me:

sudo pip3 install --proxy https://{proxy}:{port} {BINARY}
Answered By: Ruben

Leave a Reply

Your email address will not be published. Required fields are marked *