How to disable password request for a Jupyter notebook session?

Posted on

Question :

How to disable password request for a Jupyter notebook session?

I have been launching Jupyter Notebook for years using the following command:

jupyter-notebook --port=7000 --no-browser --no-mathjax

When I try to open the jupyter on the browser it ask me for a password, even though I have never set any before.
It is important to note that If I do set the port to a value different than 7000 (eg., the default 8888) the interface will open with no problem

I am running jupyter locally, and on the following setup:

Python 3.5.2

With the following modules installed:

jupyter (1.0.0), jupyter-client (4.4.0), jupyter-console (5.0.0), jupyter-core (4.2.1), ipykernel (4.5.2), ipython (5.1.0), ipython-genutils (0.1.0), nbconvert (4.3.0), nbformat (4.2.0), notebook (4.3.0)

NOTE: I have no jupyter configurations file

Following are some of the output lines from the server:

[I 19:16:24.358 NotebookApp] Serving notebooks from local directory: /Users/my_user_name
[I 19:16:24.358 NotebookApp] 0 active kernels
[I 19:16:24.358 NotebookApp] The Jupyter Notebook is running at: http://localhost:7000/?token=aa0dab6e2d85766f3e2e4f0f6633e4473db56a56c94cac76
[I 19:16:24.358 NotebookApp] Use Control-C to stop this server and shut down all kernels (twice to skip confirmation).

And follwing are messages after I try to open it on the browser (using port 7000)

[I 19:21:56.848 NotebookApp] 302 GET /tree (::1) 8.46ms
[D 19:21:56.857 NotebookApp] Using contents: services/contents
[D 19:21:56.919 NotebookApp] Path base/images/favicon.ico served from /usr/local/lib/python3.5/site-packages/notebook/static/base/images/favicon.ico
[D 19:21:56.920 NotebookApp] Path components/jquery-ui/themes/smoothness/jquery-ui.min.css served from /usr/local/lib/python3.5/site-packages/notebook/static/components/jquery-ui/themes/smoothness/jquery-ui.min.css
[D 19:21:56.922 NotebookApp] Path components/jquery-typeahead/dist/jquery.typeahead.min.css served from /usr/local/lib/python3.5/site-packages/notebook/static/components/jquery-typeahead/dist/jquery.typeahead.min.css
[D 19:21:56.923 NotebookApp] Path style/style.min.css served from /usr/local/lib/python3.5/site-packages/notebook/static/style/style.min.css
[D 19:21:56.925 NotebookApp] Path auth/css/override.css served from /usr/local/lib/python3.5/site-packages/notebook/static/auth/css/override.css
[D 19:21:56.926 NotebookApp] Path components/es6-promise/promise.min.js served from /usr/local/lib/python3.5/site-packages/notebook/static/components/es6-promise/promise.min.js
[D 19:21:56.926 NotebookApp] Path components/requirejs/require.js served from /usr/local/lib/python3.5/site-packages/notebook/static/components/requirejs/require.js
[D 19:21:56.933 NotebookApp] Path base/images/logo.png served from /usr/local/lib/python3.5/site-packages/notebook/static/base/images/logo.png
[D 19:21:56.934 NotebookApp] 200 GET /login?next=%2Ftree (::1) 80.86ms
[D 19:21:57.001 NotebookApp] Path custom.css served from /usr/local/lib/python3.5/site-packages/notebook/static/custom/custom.css
[D 19:21:57.003 NotebookApp] 304 GET /custom/custom.css (::1) 3.11ms
[D 19:21:57.341 NotebookApp] Path auth/js/main.min.js served from /usr/local/lib/python3.5/site-packages/notebook/static/auth/js/main.min.js
[D 19:21:57.344 NotebookApp] 200 GET /static/auth/js/main.min.js?v=20161219191623 (::1) 3.57ms

At this point there is a page from jupyter asking me to insert a password I have never set before.

SOLVED!

With latest update of notebook module (4.3.1) the problem has been solved.

Once the jupyter notebook is launched the user is prompted to paste a URL into the browser at the first connection:

Copy/paste this URL into your browser when you connect for the first time,
to login with a token:
    http://localhost:7000/?token=32be0f5ee74cfe521187bc479855ce8b9fbab9e8021701c9

This solved the problem!

Answer #1:

The following is very unsafe, but you can remove the password completely with:

jupyter notebook --ip='*' --NotebookApp.token='' --NotebookApp.password=''

Without --NotebookApp.password='', when connecting from a remote computer to a local Jupyter launched simply with:

jupyter notebook --ip='*'

it still asks for a password for security reasons, since users with access can run arbitrary Python code on the server machine!

Note that on my machine, running just:

jupyter notebook

already opens a logged-in window on my browser, and stdout contains:

    To access the notebook, open this file in a browser:
        file:///home/ciro/.local/share/jupyter/runtime/nbserver-3286-open.html
    Or copy and paste one of these URLs:
        http://localhost:8888/?token=7c9265bf9df5f57cf5da88f410a71b097e2548ae375826b7
     or http://127.0.0.1:8888/?token=7c9265bf9df5f57cf5da88f410a71b097e2548ae375826b7

so if your browser is not opening automatically, you can try one of those links, which seem to have a login token on them, and then investigate why your browser is not opening automatically.

Tested on Jupyter 4.4.x, Ubuntu 18.04.

Answer #2:

How to avoid “Invalid credentials” by disabling jupyter Notebook Password & Token

First open Anaconda Prompt

  1. Enter the command jupyter notebook –generate-config

enter image description here

  1. From jupyter directory ,edit the jupyter_notebook_config.py

made changes into the following command

 c.NotebookApp.token = ''
 c.NotebookApp.password = u''
 c.NotebookApp.open_browser = True
 c.NotebookApp.ip = 'localhost'

Now launch the jupyter notebook from anaconda navigator definitely the problem will be resolved as soon..

Answered By: kowsalya

Answer #3:

If you are trying to run from docker without password just use CMD like bellow:

CMD ["jupyter", "notebook", "--no-browser","--NotebookApp.token=''","--NotebookApp.password=''"]
Answered By: tomkri

Answer #4:

Notebook 4.3.0 has enabled login security by default. The token to enter in the password field is printed in the output of the notebok server during startup (or can be included directly in the URL)

The Jupyter Notebook is running at: http://0.0.0.0:8888/?token=f3e7fa23fb7e347ad05914368b625416b7a95a674dc078f7

See http://jupyter-notebook.readthedocs.io/en/latest/security.html#server-security for more info, including disabling the feature.

However, this would not explain why you get the password prompt when running on one port but not on another

Answered By: okoethibm

Answer #5:

The same issue occured on my machine since the last update of the jupyter-notebook package. After installing version

jupyter-notebook-4.3.0-1-any.pkg.tar.xz

it prompted me for a password I never set.
Downgrading to

jupyter-notebook-4.2.3-1-any.pkg.tar.xz

worked for me keeping the system a productive environment. Of course this is just a fast patch.

I also wondered where the password was set since I don’t have an explicit config file in my .jupyter-folder. Setting up my own with

password_required=False

made no difference.

Answered By: YjRtPya

Answer #6:

You can first create a jupyter config file with:

cd ~/.jupyter

jupyter notebook –generate-config
Then set the c.NotebookApp.token parameter to an empty string in the configuration file created

c.NotebookApp.token = ”

As mentioned in comment, Setting to an empty string disables authentication altogether, which is NOT RECOMMENDED.

Answered By: Ranjita Shetty

Answer #7:

I solved the token authentication by replacing the password inside jupyter_notebook_config.json by running jupyter notebook password on the command line:

(base) C:WINDOWSsystem32>jupyter notebook list
http://localhost:8888/ :: C:Users320089053
http://localhost:8889/ :: C:Users320089053

(base) C:WINDOWSsystem32>jupyter notebook list
Enter password:
Verify password:
[NotebookPasswordApp] Wrote hashed password to C:Users320089053.jupyterjupyter_notebook_config.json
Answered By: wilma88

Answer #8:

For me, the solutions described above was not applicable in Docker.

The following solution works like a charm on Linux:

Details:

  • used image: tensorflow/tensorflow:latest-py3-jupyter
  • password I configured: ‘password’
  • run Jupyter as a user (not root)

Steps to start Jupyter in Docker with your pre-defined password:

  1. export JUPYTER_TOKEN='password'
  2. docker run -it --rm -p 8888:8888 -u $(id -u ${USER}):$(id -g ${USER}) -e JUPYTER_TOKEN=$JUPYTER_TOKEN -v /home/<user>/jupyter:/tf/ tensorflow/tensorflow:latest-py3-jupyter
  3. open http://localhost:8888 and use ‘password’ as your password
  4. save password in ypur browser

For me, that is the easiest way to get rid of the annoying token authentication.

Answered By: zappee

Leave a Reply

Your email address will not be published.