Exception in thread “main” java.lang.NoClassDefFoundError: org/openqa/selenium/WebDriver

Posted on

Problem :

I have added the most updated Selenium dependency in my pom.xml

<dependency>
    <groupId>org.seleniumhq.selenium</groupId>
    <artifactId>selenium-java</artifactId>
    <version>3.7.1</version>
</dependency>

I ran
mvn clean install
inside the directory with my pom.xml and I have also imported the correct classes in my app class as per the Selenium documentation

import org.openqa.selenium.WebDriver;
import org.openqa.selenium.firefox.FirefoxDriver;

However when i try and run my main method, I get the following error

Exception in thread "main" java.lang.NoClassDefFoundError: 
org/openqa/selenium/WebDriver

I look in my ~/.m2/repository folder and I don’t see an openqa folder but instead I see a seleniumhq folder.

Why didn’t maven install the openqa folder, and why does the documentation say to import from org.openqa… when that never exist in my jar repository. I’m very confused, I just want to be able to import selenium Webdriver successfully while having it in my local repository.

Solution :

Firstly, check properly if you have all important dependencies for your program.
Secondly, I had similar error while running maven project:

Caused by: java.lang.NoClassDefFoundError: org/openqa/selenium/JavascriptExecutor

And this problem was because of inappropriate plugin, because I tested different versions of Selenium and it didn’t help me.

So when I changed maven-jar-plugin:

<plugin>
<groupId>org.apache.maven.plugins</groupId>
<artifactId>maven-jar-plugin</artifactId>
<version>3.1.0</version>
 <configuration>
   <archive>
        <manifest>
             <addClasspath>true</addClasspath>
             <classpathPrefix>lib/</classpathPrefix>
             <mainClass>your_main_class</mainClass>
        </manifest>
   </archive>
 </configuration>
</plugin>

to maven-shade-plugin plugin:

<plugin>
    <groupId>org.apache.maven.plugins</groupId>
    <artifactId>maven-shade-plugin</artifactId>
    <version>3.0.0</version>
    <executions>
       <execution>
            <phase>package</phase>
            <goals>
               <goal>shade</goal>
            </goals>
            <configuration>
                 <transformers>
                    <transformer 
implementation="org.apache.maven.plugins.shade.resource.ManifestResourceTransformer">
                        <mainClass>your_main_class</mainClass>
                    </transformer>
                 </transformers>
             </configuration>
       </execution>
    </executions>
</plugin>

The issue was gone.
The difference between plugins you can find here.


In addition, sometimes we upgrade our libraries even with same method name. Due this different in version, we get NoClassDefFoundError or NoSuchMethodError at runtime when one library was not compatible with such an upgrade.

Java build tools and IDEs can also produce dependency reports that tell you which libraries depend on that JAR. Mostly, identifying and upgrading the library that depends on the older JAR resolve the issue.


To summarize:

  • try to change versions of Selenium, if it contains all dependencies;
  • try to add necessary dependencies if you don’t have it;
  • try to check folder of maven if it has or not what says specific error;
  • try to play with plugins if nothing helps above.

Encountered this error in Eclipse IDE. In Eclipse go to Project properties and in Java Build Path just add selenium jars in Classpath instead of Modulepath. Then under the Project tab on the top do a Clean to remove earlier buiid and then do a Run.

NoClassDefFoundError

NoClassDefFoundError in Java occurs when Java Virtual Machine is not able to find a particular class at runtime which was available at compile time. For example, if we have resolved a method call from a class or accessing any static member of a Class and that Class is not available during run-time then JVM will throw NoClassDefFoundError.

The error you are seeing is :

Exception in thread "main" java.lang.NoClassDefFoundError: 
org/openqa/selenium/WebDriver

This clearly indicates that Selenium is trying to resolve the particular class at runtime from org/openqa/selenium/WebDriver which is no more available.

As you mentioned of looking into ~/.m2/repository folder, the maven folder structure for Selenium v3.7.1 (on Windows) is as follows :

C:Users<user_name>.m2repositoryorgseleniumhqseleniumselenium-java3.7.1

So when you see a seleniumhq folder, it is pretty much expected.


What went wrong :

From all the above mentioned points it’s clear that the related Class or Methods were resolved from one source Compile Time which was not available during Run Time.

This situation occurs if there are presence of multiple sources to resolve the Classes and Methods through JDK / Maven / Gradle.


Solution :

Here are a few steps to solve NoClassDefFoundError :

  • While using a Build Tool e.g. Maven or Gradle, remove all the External JARs from the Java Build Path. Maven or Gradle will download and resolve all the required dependencies.
  • If using Selenium JARs within a Java Project add only required External JARs within the Java Build Path and remove the unused one.
  • While using Maven, either use <artifactId>selenium-java</artifactId> or <artifactId>selenium-server</artifactId>. Avoid using both at the same time.
  • Remove the unwanted other <dependency> from pom.xml
  • Clean you Project Workspac within your IDE periodically only to build your project with required dependencies.
  • Use CCleane tool to wipe away the OS chores periodically.
  • While you execute a Maven Project always do maven clean, maven install and then maven test.

Are you using an IDE or working from command line? In Eclipse for example you can force downloading all dependencies by right clicking on your project, going to Maven menu item and then selecting Update Project. Then check the “Force Update of Snapshots/Releases” checkbox.

If you are opening from command line do:

mvn clean install -U

from your project path.

This is happening because you are selecting jar files under modulepath, you should add them under class path.

  • org.openqa.selenium is the package in the selenium-api-{version}.jar under the seleniumhqseleniumselenium-api folder.
  • org.openqa.selenium.firefox is the package in the selenium-firefox-driver-{version}.jar under the seleniumhqseleniumselenium-firefox-driver folder.

So there is no openqa folder, it’s just the package name under the seleniumhq folder, you should have a check into these jar.

It’s hard to say what caused NoClassDefFoundError exception without project structure and code detail. The exception is not the same as ClassNotFoundException. Maybe this answer https://stackoverflow.com/a/5756989/5374508 would be helpful.

What worked for me was to add this dependency to pom.xml:

    <dependency>
        <groupId>com.google.guava</groupId>
        <artifactId>guava</artifactId>
        <version>25.0-jre</version>
    </dependency>

I was getting below error from past 2 days and what helped me was to remove all the selenium extra dependencies like selenium-support, selenium-chrome-driver etc and only keeping the below dependencies in POM file.

Error:-

java.lang.NoClassDefFoundError: org/openqa/selenium/HasAuthentication

at java.base/java.lang.ClassLoader.defineClass1(Native Method)
at java.base/java.lang.ClassLoader.defineClass(ClassLoader.java:1012)
at java.base/java.security.SecureClassLoader.defineClass(SecureClassLoader.java:150)
at java.base/jdk.internal.loader.BuiltinClassLoader.defineClass(BuiltinClassLoader.java:862)
at java.base/jdk.internal.loader.BuiltinClassLoader.findClassOnClassPathOrNull(BuiltinClassLoader.java:760)
at java.base/jdk.internal.loader.BuiltinClassLoader.loadClassOrNull(BuiltinClassLoader.java:681)

Dependencies in the pom file after removing all other:-

<dependencies>
    <dependency>
                <groupId>org.seleniumhq.selenium</groupId>
                <artifactId>selenium-java</artifactId>
                <version>4.1.1</version>
            </dependency>
            <dependency>
                <groupId>org.testng</groupId>
                <artifactId>testng</artifactId>
                <version>7.4.0</version>
                <scope>test</scope>
            </dependency>
    </dependencies>

Have encountered this issue while running selenium test in eclipse IDE.

Navigate to following path:

1.Properties >> Java build path >> Libraries.

2.Add all selenium jars in Classpath instead of Modulepath.

3.Apply and close modal.

4.Now go to build path and click on “Configure Build Path”.

5.Now run the selenium test.

Leave a Reply

Your email address will not be published. Required fields are marked *