Error (-215) size.width>0 && size.height>0 occurred when attempting to display an image using OpenCV

Posted on

Question :

Error (-215) size.width>0 && size.height>0 occurred when attempting to display an image using OpenCV

I am trying to run a simple program that reads an image from OpenCV. However, I am getting this error:

error: ......moduleshighguisrcwindow.cpp:281: error: (-215) size.width>0 && size.height>0 in function cv::imshow

Any idea what this error means?

Here is my code:

from matplotlib import pyplot as plt
import numpy as np
import cv2

img = cv2.imread('C:\Utilisateurs\Zeineb\Bureau\image.jpg',0)
cv2.imshow('image',img)
cv2.waitKey(0)
cv2.destroyAllWindows()

Answer #1:

“error: (-215)” means that an assertion failed. In this case, cv::imshow asserts that the given image is non-empty: https://github.com/opencv/opencv/blob/b0209ad7f742ecc22de2944cd12c2c9fed036f2f/modules/highgui/src/window.cpp#L281

As noted in the Getting Started with Images OpenCV Python tutorial, if the file does not exist, then cv2.imread() will return None; it does not raise an exception.

Thus, the following code also results in the “(-215) size.width>0 && size.height>0” error:

img = cv2.imread('no-such-file.jpg', 0)
cv2.imshow('image', img)

Check to make sure that the file actually exists at the specified path. If it does, it might be that the image is corrupted, or is an empty image.

Answered By: Daniel Trebbien

Answer #2:

This error shows when either,

  1. path of the image is wrong.
  2. name of the image is wrong.

We can check it by using ‘print(img)‘ command after ‘img = cv2.imread('C:\Utilisateurs\Zeineb\Bureau\image.jpg',0)‘ if output is ‘None’ then either path or name of the image is wrong. If output is matrix then image read is successful.
In code ‘cv2.waitKey(0)‘ zero shows the millisecond for which image will appear on the screen so it should be greater than zero something like 5000.

Answered By: Saurabh Kumar

Answer #3:

Make sure you have given the correct path of image.
This error comes only when you have given wrong path.

Answered By: veer varun singh

Answer #4:

    img=cv2.imread('testpaper01-01.png')
    cv2.imshow('image',img)
    cv2.waitKey(0)
    cv2.destroyAllWindows()

You have to mention the same format of your image file in the code(eg:-.jpg/.png/.jpeg/.tif etc.) and the directory of the image file must be same as the source code, I also got the same error but I rectified this way

Answered By: Roshan

Answer #5:

import numpy as np
import cv2

cap = cv2.VideoCapture(0)
while(True):
    # Capture frame-by-frame
    ret,frame = cap.read()
    cv2.rectangle(frame, (100, 100), (200, 200), [255, 0, 0], 2)
    # Display the resulting frame
    cv2.imshow('frame',frame)
    if cv2.waitKey(25) & 0xFF == ord('q'):
        break

# When everything done, release the capture
cap.release()
cv2.destroyAllWindows() 

**If the camera access for devices is OFF, this code gives an error ;kind of this: cv2.imshow(‘frame’,frame) cv2.error: OpenCV(4.0.0)
C:projectsopencv-pythonopencvmoduleshighguisrcwindow.cpp:350:
error: (-215:Assertion failed) size.width>0 && size.height>0 in
function ‘cv::imshow’

So You should turn ON it**
Answered By: Serhat Yarat

Answer #6:

I got the same error on Windows. However, none of answers helps me. I realised that the issue is single backslash () instead of double backslashes (\) on image path. For the difference, see the link.

Problematic scenario:

import cv2
mypath = "D:temptemp.png"
img = cv2.imread(mypath, 1)
cv2.imshow('test', img)
cv2.waitKey(0)
cv2.destroyAllWindows()

Traceback (most recent call last):
  File "<input>", line 1, in <module>
cv2.error: OpenCV(4.4.0) C:UsersappveyorAppDataLocalTemp1pip-req-build-2b5g8ysbopencvmoduleshighguisrcwindow.cpp:376: error: (-215:Assertion failed) size.width>0 && size.height>0 in function 'cv::imshow'

Fixed scenario:

import cv2
mypath = "D:\temp\temp.png"
img = cv2.imread(mypath, 1)
cv2.imshow('test', img)
cv2.waitKey(0)
cv2.destroyAllWindows()

I hope it helps others who have similar experiences.

Answered By: ozturkib

Answer #7:

This error occurs when you are trying to show an empty image. The image was probably not loaded correctly and could be due to a non-existent image, incorrect file path, or incorrect file extension when using cv2.imread(). You can check if the image was loaded properly by printing out its shape

image = cv2.imread('picture.png')
print(image.shape)

You will get something like this which returns a tuple of the number of rows, columns, and channels

(400, 391, 3)

If OpenCV was unable to load the image, it will throw this error when trying to print the shape

AttributeError: ‘NoneType’ object has no attribute ‘shape’

Answered By: nathancy

Answer #8:

I think it depends on the IDE + path of the image location issues

  1. In python IDLE you can directly run file from same folder where picture is there
example 
img = cv2.imread("kang34.jpg", 0)  # direct use 
  1. In IntelliJ IDEA you have to give full path of the image where picture is located
example 
img = cv2.imread("C:\Users\DEBASISH\AppData\Local\Programs\Python\Python36\Projects\kang34.jpg", 0)  # use proper syntax and full path of image location
Answered By: debasishdeb

Leave a Reply

Your email address will not be published.