Django + MySQL on Mac OS 10.6.2 Snow Leopard

Posted on

Question :

Django + MySQL on Mac OS 10.6.2 Snow Leopard

There were some excellent answers to this question already, however, they are now outdated.

I’ve been able to get the module installed, but “python runserver” fails with

 iMac:myproject drhoden$ python runserver
 Validating models...
 Unhandled exception in thread started by <function inner_run at 0x10496f0>
 Traceback (most recent call last):
   File "/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/site-packages/django/core/management/commands/", line 48, in inner_run
   File "/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/site-packages/django/core/management/", line 249, in validate
     num_errors = get_validation_errors(s, app)
   File "/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/site-packages/django/core/management/", line 22, in get_validation_errors
     from django.db import models, connection
   File "/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/site-packages/django/db/", line 41, in <module>
     backend = load_backend(settings.DATABASE_ENGINE)
   File "/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/site-packages/django/db/", line 17, in load_backend
     return import_module('.base', 'django.db.backends.%s' % backend_name)
   File "/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/site-packages/django/utils/", line 35, in import_module
   File "/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/site-packages/django/db/backends/mysql/", line 13, in <module>
     raise ImproperlyConfigured("Error loading MySQLdb module: %s" % e)
 django.core.exceptions.ImproperlyConfigured: Error loading MySQLdb module: dynamic module does not define init function (init_mysql)

 ^CiMac:segisys drhoden$ 

Likewise, from the python shell:

iMac:myproject drhoden$ python
Python 2.6.4 (r264:75821M, Oct 27 2009, 19:48:32) 
[GCC 4.0.1 (Apple Inc. build 5493)] on darwin
Type "help", "copyright", "credits" or "license" for more information.
>>> import MySQLdb
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "build/bdist.macosx-10.3-fat/egg/MySQLdb/", line 19, in <module>

  File "build/bdist.macosx-10.3-fat/egg/", line 7, in <module>
  File "build/bdist.macosx-10.3-fat/egg/", line 6, in __bootstrap__
ImportError: dynamic module does not define init function (init_mysql)

Using MySQL-python-1.2.3c1 with setuptools-0.6c11-py2.6.egg

Any help would be appreciated.

Answer #1:

I have ultimately solved my own problem, with of course, the subconscious and conscious help from the many posts, blogs, and mail logs I’ve read. I would give links if I could remember.

In a nutshell, I reinstalled EVERYTHING using MacPorts.

After editing ~/.bash_profile and commenting out all the previous modifications to ${PATH}, I downloaded the dmg for Snow Leopard and ran through its installation.

Then opened the terminal and ran the self update.

sudo port selfupdate
sudo port install python26

That second part, installing Python 2.6, took forever. But when it completed it prompted me with the following:

To fully complete your installation and make python 2.6 the default, please run

sudo port install python_select  
sudo python_select python26

I did both and they went quick.

I forgot to mention how handy ‘port search ‘ command is. I searched for ‘mysql’ and similar to find the thing to type after ‘install’. But I proceeded with reinstalling both the client and server for MySQL. Perhaps I did this in reverse order, but the end result worked fine.

sudo port install mysql5
--->  Installing mysql5 @5.1.41_0
The MySQL client has been installed.
If you also want a MySQL server, install the mysql5-server port.

So naturally:

sudo port install mysql5-server

I love how the so many of the macports installations give you feedback as to what to do next. At the end of the server installation, it said the following:

* In order to setup the database, you might want to run
* sudo -u _mysql mysql_install_db5
* if this is a new install

It was a new install for me (didn’t have any local schemas). For completeness, and for my own reference, here is the output of running that command:

Installing MySQL system tables...
Filling help tables...

To start mysqld at boot time you have to copy
support-files/mysql.server to the right place for your system

To do so, start the server, then issue the following commands:

/opt/local/lib/mysql5/bin/mysqladmin -u root password 'new-password'
/opt/local/lib/mysql5/bin/mysqladmin -u root -h iMac.local password 'new-password'

Alternatively you can run:

which will also give you the option of removing the test
databases and anonymous user created by default.  This is
strongly recommended for production servers.

See the manual for more instructions.

You can start the MySQL daemon with:
cd /opt/local ; /opt/local/lib/mysql5/bin/mysqld_safe &

You can test the MySQL daemon with
cd /opt/local/mysql-test ; perl

Please report any problems with the /opt/local/lib/mysql5/bin/mysqlbug script!

The latest information about MySQL is available at
Support MySQL by buying support/licenses from

Almost done. Earlier in my ‘port search’ing I came across this interesting port:

py26-mysql @1.2.2 (python, devel, databases)
Python interface to mysql

With much, much hope that this would provide me with MySQLdb package, I installed it (and it did).

sudo port install py26-mysql

Afterwords I cranked up the python interpreter attempted to import MySQLdb, the very thing in my way all this time.

iMac:~ drhoden$ python
Python 2.6.4 (r264:75706, Dec 15 2009, 18:00:14) 
[GCC 4.2.1 (Apple Inc. build 5646) (dot 1)] on darwin
Type "help", "copyright", "credits" or "license" for more information.
>>> import MySQLdb
/opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/site-packages/MySQLdb/ DeprecationWarning: the sets module is deprecated from sets import ImmutableSet

A warning, but It worked!!

Just one more thing:

sudo port install py26-django

After all of this I was finally able to crank up my Django project and remotely connect to my company’s MySQL server!! It may not have been necessary to reinstall Django using MacPorts, but I wasn’t going to risk complications.

Answered By: Daniel Rhoden

Answer #2:

I wrote a blog post a few months ago following my successful installation of MySQL on Snow Leopard:

If you follow those steps, it should (theoretically) fix your problem (which sounds like it’s caused by a mix of 32-bit and 64-bit software).

By the way, I’m not trying to self-promote here; the text in the blog post is basically what I would’ve posted here, and I’m trying to apply DRY to more areas of my life 🙂

Answered By: jakeboxer

Answer #3:

This happens when you have mixed 32 and 64bit software.

Basically, for Snow Leopard, you need to install MySQL 64bit package (which still is listed as 10.5, but that is no problem) , after that do an easy install of python-mysql again. All will work.

Answered By: kibitzer

Leave a Reply

Your email address will not be published. Required fields are marked *